28th March 2018

Flex APIs FlightStats Planned Maintenance Complete

We finished applying a security upgrade during our 2018-03-28 normal Wednesday maintenance window from 10:00 AM to 12:00 PM UTC -7. Customers previously connecting to our systems with TLS 1.x are now required to connect with TLS 1.2. To avoid further disruption, please check with your system administrator and apply any required security upgrades.