Investigating an issue with FlightStats.com user registration
Incident Report for Cirium
Resolved
This incident has been resolved.
Posted Feb 02, 2023 - 16:22 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 02, 2023 - 15:37 UTC
Investigating
We are investigating an issue whereby users registering for access to FlightStats.com are unable to verify their email address. Any affected users should contact our Help Desk for support. We will provide an update shortly.
Posted Feb 02, 2023 - 13:43 UTC
This incident affected: FlightStats.com.