Agent Advantage Site Outage
Incident Report for Cirium
Resolved
This incident has been resolved.
Posted Jan 25, 2023 - 21:27 UTC
Investigating
We're currently investigating an outage with the Trips Agent Advantage site. This has been escalated and is being treated with priority. Our apologies for the inconvenience. Please contact our Help Desk if you have any questions.
Posted Jan 25, 2023 - 19:01 UTC
This incident affected: Proactive & Traveler Services.