Investigating: Sky API Trial Credential Creation Delays

Incident Report for Cirium

Investigating

We are currently investigating an issue affecting some Cirium Sky API trial credential requests. Impacted users may experience trial credentials remaining in a Pending Creation state and may not receive access as expected. Our team is actively investigating the issue and working to resolve it as quickly as possible. We will provide further updates as they become available. We apologize for any inconvenience caused. Please contact our Help Desk if you have any questions.
Posted Sep 07, 2026 - 09:20 UTC
This incident affects: Cirium Sky™ APIs.