Our engineers have successfully completed the fleets data update. The latest data will be applied to all affected products as per their individual update schedules. An internal RCA will be carried out to understand the cause(s) of today's and yesterday's incidents, and steps put in place to enhance platform resilience.
Posted Apr 14, 2026 - 11:41 UTC
Investigating
We’re currently experiencing degraded performance issues affecting all products where fleets data is surfaced, including, but not limited to Fleets Analyzer and Cirium Sky™ Warehouse. It appears that data was not published overnight on Monday, 13th April, resulting in stale data in all affected services. The issue has also meant that no news articles have been published in Dashboard or Pulse since midnight (UTC). Our engineers are working to restore the affected services and address the underlying cause. We sincerely apologize for any inconvenience caused. The next update will be posted on or before 12:25 UTC.
Posted Apr 14, 2026 - 08:27 UTC
This incident affected: Dashboard, Fleets Analyzer, Values Analyzer, Profiles, Asset Watch, Ground Events, Fleet Insights, Pulse, Cirium Sky™ Warehouse, and Professional Data Services.