Cirium Sky Stream data issue

Incident Report for Cirium

Resolved

This incident has been resolved.
Posted Sep 15, 2025 - 13:04 UTC

Investigating

Our engineers are investigating an issue affecting the Cirium NOTAMS Sky Stream. Customers may observe a low frequency of data updates. A further update will follow. Please contact us if you have questions or require further assistance.
Posted Sep 15, 2025 - 09:07 UTC
This incident affected: Cirium Sky™ Stream.