We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 13:43 UTC
Update
Cirium is partnering closely with AWS and whilst some services are starting to recover, a number of services remain impacted. Cirium will prioritise any additional remediation work required to ensure all our services are fully restored once AWS has confirmed full restoration. Next update is expected at 16:30 UTC.
Posted Oct 20, 2025 - 13:37 UTC
Update
AWS services are starting to recover and come back online. We are prioritising any additional remediation work required to ensure all Cirium services are restored to full service.
Posted Oct 20, 2025 - 10:11 UTC
Identified
We are currently experiencing disruption due to the current AWS outage. Amazon has reported "We can confirm increased error rates and latencies for multiple AWS Services in the US-EAST-1 Region". This is affecting multiple Cirium services, including Sky Warehouse, Sky Stream, Trips, API and Professional Data Services. We are closely monitoring the issue and will provide an update as soon as possible. Also refer to https://health.aws.amazon.com/health/status.
Posted Oct 20, 2025 - 09:03 UTC
This incident affects: Cirium Sky™ APIs, Cirium Sky™ Warehouse, Cirium Sky™ Stream, Proactive & Traveler Services, Professional Data Services, Insight Workbooks, Cirium Journey™ OTP Awards AI, and Cirium Journey™ OTP Improvement AI.