Intermittent Errors - FlightStats Flight Status API

Incident Report for Cirium

Monitoring

Engineering has identified intermittent database connection issues impacting the Flight Status API. A change has been applied and connections have stabilized. The team continues to monitor the service and analyze the issue, with further updates to follow as needed. Please contact our Help Desk if you encounter any errors.
Posted Mar 25, 2026 - 20:09 UTC

Investigating

We are investigating intermittent server errors impacting the FlightStats Flight Status API, first observed around 12:30 AM UTC on 2026-03-25. A limited number of customers may be impacted. The next update will be provided by 02:00 AM UTC on 2026-03-26.
Posted Mar 25, 2026 - 18:49 UTC
This incident affects: Cirium Sky™ APIs.