London Heathrow Closure - 21st March 2025

Incident Report for Cirium

Resolved

This incident has been resolved.
Posted Mar 24, 2025 - 09:19 UTC

Monitoring

Following the announcement of the closure of London Heathrow (LHR) today, Friday 21st March, Cirium has taken the decision to mark all scheduled departures as cancelled. We are monitoring the situation closely, and will continue to review over the weekend.

For travellers, you can check your flight at https://www.flightstats.com/v2/, or on the FlightStats mobile app, however we recommend contacting your airline directly to confirm the status and discuss alternative arrangements.
Posted Mar 21, 2025 - 11:26 UTC