Cirium Sky Warehouse Flight data update issue

Incident Report for Cirium

Update

Our engineering team is continuing the task of backfilling the missing flights data, affecting in particular the 23rd and 24th March. A further update will be posted tomorrow. We appreciate your continued patience whilst we work on this critical data fix.
Posted Mar 31, 2025 - 13:25 UTC

Update

We are continuing to work on backfilling the flights data in Cirium Sky™ Warehouse. A further update will be provided shortly.
Posted Mar 27, 2025 - 15:15 UTC

Monitoring

A fix has been implemented and we're monitoring the results. Flight data is expected to take up to the next 1-2 hours to be fully caught up. We are continuing to work on backfilling the flights data.
Posted Mar 25, 2025 - 22:34 UTC

Identified

A fix has been identified and we expected flight status updates to resume in the next 2 hours. We will provide another update here once our services are stabilized. Please contact our Help Desk with any questions.
Posted Mar 25, 2025 - 19:34 UTC

Investigating

Engineering is currently investigating an issue with populating the Flights, Codeshares, and Diversions tables with new data in the Cirium Sky™ Warehouse. The incident started on Sunday, March 23, 2025 at approx. 3:00 AM UTC and we are working to remediate the problem with the highest priority. Please contact our Help Desk if you have any questions.
Posted Mar 24, 2025 - 21:57 UTC
This incident affects: Cirium Sky™ Warehouse.