Cirium Sky Stream degraded performance

Incident Report for Cirium

Resolved

This incident has been resolved.
Posted Jan 28, 2026 - 11:43 UTC

Identified

We’re experiencing degraded performance with Cirium Sky Stream caused by maintenance activity on an upstream dataset. Users may notice the late arrival of status updates. We expect the service to restored by 12:00 UTC, however it might take a little longer for the systems to fully recover. Please accept our apologies for any disruption caused.
Posted Jan 28, 2026 - 11:07 UTC
This incident affected: Cirium Sky™ Stream.