Investigating issues with the delivery of FlightStats.com flight alerts
Incident Report for Cirium
Resolved
Our team has identified and fixed the issue affecting the delivery of flight alerts. Please accept our apologies for the interruption to the service and don't hesitate to contact us if we can be of further assistance.
Posted Jan 24, 2023 - 13:54 UTC
Investigating
We are investigating an issue affecting the delivery of FlightStats.com flight alerts. Users are not receiving flight alerts despite having available credits. We apologise for the disruption caused and will provide an update shortly.
Posted Jan 24, 2023 - 12:17 UTC
This incident affected: FlightStats.com.