Trip Center is unresponsive
Incident Report for Cirium
Resolved
This incident has been resolved.
Posted Nov 21, 2024 - 12:50 UTC
Investigating
We are currently experiencing an outage affecting Trip Center, https://trip.flightstats.com. Our engineers are investigating and we will provide an update shortly. Please accept our apologies for any disruption caused by this issue.
Posted Nov 21, 2024 - 12:25 UTC
This incident affected: Proactive & Traveler Services.