Flightstats.com unable to save alerts

Incident Report for Cirium

Resolved

This incident has been resolved.
Posted Sep 17, 2025 - 05:58 UTC

Investigating

We’re currently experiencing degraded performance issues with Flightstats.com. Our team is currently working to restore normal performance levels. We apologize for any inconvenience. Flightstats.com users may be affected.
Posted Sep 17, 2025 - 04:21 UTC
This incident affected: FlightStats.com.