Degraded Performance Issues - Cirium Sky API Platform, Flightstats.com and Trips Data Services

Incident Report for Cirium

Resolved

This incident has been resolved. Please accept our apologies for any disruption caused and contact the Help Desk for further assistance.
Posted Mar 17, 2026 - 11:53 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 17, 2026 - 11:33 UTC

Update

We are continuing to investigate this issue.
Posted Mar 17, 2026 - 11:30 UTC

Update

We are continuing to investigate this issue.
Posted Mar 17, 2026 - 11:14 UTC

Investigating

We’re currently experiencing degraded performance issues with the Cirium Sky API platform, Flightstats.com and Trip Center. Users may observe a high number of server errors. Our team is currently working to restore normal performance levels. We apologize for any inconvenience. We will post a further update no later than 14:45 UTC.
Posted Mar 17, 2026 - 10:46 UTC
This incident affected: Cirium Sky™ APIs, Proactive & Traveler Services, and FlightStats.com.