Investigating issue with Cirium Dashboard and Fleets Analyzer

Incident Report for Cirium

Investigating

A subset of users have reported blank screens when attempting to access the Cirium Dashboard and Fleets Analyzer. Our engineers are investigating. We will post a further update on or before 20:00 UTC.
Posted Nov 24, 2025 - 12:26 UTC
This incident affects: Dashboard and Fleets Analyzer.