Trip Center is currently unavailable

Incident Report for Cirium

Resolved

This incident has been resolved.
Posted Feb 03, 2025 - 12:51 UTC

Investigating

We are investigating an outage of Trip Center, https://trip.flightstats.com/. A further update will follow shortly. Please contact us if you have questions or require further assistance.
Posted Feb 03, 2025 - 11:10 UTC
This incident affected: Professional Data Services.