Investigating issues with Flight Track APIs

Incident Report for Cirium

Investigating

We are investigating an issue with Developer Flightstats - Flight Track APIs. We are currently experiencing no response from server.

We apologies for any inconvenience caused and will post a further update no later than 8th April 2026, 08:37 UTC.
Posted Apr 08, 2026 - 04:41 UTC
This incident affects: Cirium Sky™ APIs.