Ongoing Incident - Cirium PDS SFTP file deliveries – 22nd July 2026

Incident Report for Cirium

Monitoring

Cirium’s SFTP service has now been restored, and we are in the process of uploading files to the relevant customer sub-folders located in this service: (eft.lexisnexisrisk.com). Once all deliveries have been completed we will provide a final update and resolution here.

Once again, we apologise for the inconvenience caused.
Posted Jun 22, 2026 - 12:21 UTC

Investigating

Cirium’s SFTP service is experiencing a degradation in service. Any customer attempting to connect and download their files using this service (eft.lexisnexisrisk.com) will currently be unable to do so. We are actively working on restoring the service and will provide regular updates and also advise when this incident is resolved.

Please accept our apologies for the inconvenience caused.
Posted Jun 22, 2026 - 10:13 UTC
This incident affects: Professional Data Services.