Flights data outage

Incident Report for Cirium

Resolved

This incident has been resolved. All Cirium products and systems affected by the earlier flight data outage are operational, with no data degradation. Thank you for your patience and understanding during the outage. Please contact our Help Desk if you have any ongoing issues or follow-up questions.
Posted Oct 30, 2025 - 14:24 UTC

Monitoring

Our services are recovering, with flight alerts being delivered normally. We are continuing to monitor performance closely and will provide further updates as required.
Posted Oct 30, 2025 - 11:44 UTC

Identified

We suffered an outage of an upstream system from 8:09 to 9:33 UTC today, 29th October, affecting the processing of flight data. This outage has impacted flight status feeds, updates and flight alerts. The underlying issue has been resolved and we are working to restore all affected services. We will provide a further update no later than 14:00 UTC. For any questions or assistance, please contact our Help Desk.
Posted Oct 30, 2025 - 10:25 UTC
This incident affected: Cirium Sky™ APIs, Cirium Sky™ Stream, Proactive & Traveler Services, and FlightStats.com.