Investigating issues with Fleets Analyzer - Trend and Projection tabs

Incident Report for Cirium

Investigating

We are investigating issues with the Fleets Analyzer - Trend and Projection tabs. When applying Event Type filters (e.g. Deliveries, Purchased, Lease Start) in the Aircraft or Aircraft Event contexts, no data is returned in Trend or Projection. Data is returned in Detail and Summary, and in Trend and Projection when applying Event Detail Type filters (e.g. Scheduled delivery of ordered aircraft, Purchased off lease, Lease extended). We will post a further update within 24 hours. Please accept our apologies for any inconvenience this issue may cause and contact our Help Desk with any questions.
Posted Mar 05, 2026 - 11:34 UTC
This incident affects: Fleets Analyzer.