Fleets Analyzer and Values Analyzer degraded perfomance

Incident Report for Cirium

Resolved

The incident has been resolved and all services are performing as expected.
Posted Feb 26, 2026 - 16:09 UTC

Investigating

Users of Fleets Analyzer and Values Analyzer may experience outages or degraded performance due to a load balancer issue . Our engineers are investigating and we will post a further update no later than 18:50 UTC. Please accept our apologies for any inconvenience this issue may cause and contact our Help Desk with any questions.
Posted Feb 26, 2026 - 10:56 UTC
This incident affected: Fleets Analyzer and Values Analyzer.