Degraded Performance Issues - PDS Fleets/Values APIs
Incident Report for Cirium
Resolved
This incident has been resolved.
Posted Nov 14, 2022 - 16:33 UTC
Update
We are continuing to investigate this issue.
Posted Nov 11, 2022 - 17:42 UTC
Investigating
Degraded Performance Issues - PDS Fleets/Values APIs

We’re currently aware of a performance issue with our PDS Fleets/Values API services, when invoking via Google Chrome. Our team is currently working to restore normal performance levels. We apologize for any inconvenience. Please contact our Help Desk if you have any questions.
Posted Nov 11, 2022 - 14:10 UTC
This incident affected: Professional Data Services.