PDS Fleets - Deliveries of incomplete data

Incident Report for Cirium

Resolved

This incident has been resolved and all processes and deliveries were successfully completed and services restored. Please contact our Help Desk should you encounter any further issues.
Posted Jun 26, 2025 - 18:15 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 26, 2025 - 13:31 UTC

Investigating

We are currently investigating an issue that has resulted in incomplete / inaccurate PDS Fleets deliveries today, 26th June 2025. This issue is also affecting PDS Ascendworldwide.com hosted API services. A further update will follow. Please contact us if you have questions or require further assistance.
Posted Jun 26, 2025 - 11:49 UTC
This incident affected: Professional Data Services.