Scheduled Maintenance - Trips Data Services - 22nd July 2026

Incident Report for Cirium

Resolved

This incident has been resolved.
Posted Jul 22, 2026 - 07:30 UTC

Investigating

We will be performing maintenance to our Trip Data Services on 22nd July 2026 from 04:30 AM to 08:30 AM UTC. During this period, the platform will undergo a series of maintenance tasks and upgrades. No extended downtime is expected, but some unavailability or reduced performance may be experienced during the maintenance window. Please contact our Help Desk if you have any questions.
Posted Jul 22, 2026 - 06:47 UTC
This incident affected: Proactive & Traveler Services.