Flight Status not updating

Incident Report for Cirium

Resolved

This incident has been resolved. All our services are running as expected and the data has caught up.
Posted Mar 26, 2025 - 09:22 UTC

Monitoring

A fix has been implemented and we're monitoring the results. Flight data is expected to take up to the next 1-2 hours to be fully caught up. We will provide another update on 2026-03-26 at 5:30 AM UTC.
Posted Mar 25, 2025 - 22:34 UTC

Update

A fix has been identified and we expected all services to resume in the next 2 hours. We will provide another update here once our services are stabilized. Please contact our Help Desk with any questions.
Posted Mar 25, 2025 - 19:33 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 25, 2025 - 17:18 UTC

Investigating

Customers are reporting no flight status updates since approximately 09:30 UTC, 25th March 2025. This is affecting several products. We are investigating with the highest priority and will provide an update as soon as possible.
Posted Mar 25, 2025 - 13:14 UTC
This incident affected: Cirium Sky™ APIs, Cirium Sky™ Stream, Proactive & Traveler Services, and FlightStats.com.