Flights data processing backlog

Incident Report for Cirium

Resolved

Our flights data is being processed as expected and the backlog has cleared.
Posted Jun 18, 2025 - 14:01 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 18, 2025 - 13:14 UTC

Identified

Our team has identified the issue and flight data processing has restarted. We expect to have caught up within the next 60 minutes.
Posted Jun 18, 2025 - 13:13 UTC

Investigating

We are currently investigating an issue that is causing a backlog in flight data processing. This is affecting Sky Data Warehouse, Sky Stream and Sky API's. A further update will be posted shortly.

Please accept our apologies for any disruption caused.
Posted Jun 18, 2025 - 13:06 UTC
This incident affected: Cirium Sky™ APIs, Cirium Sky™ Warehouse, and Cirium Sky™ Stream.