Planned Maintenance - Cirium Sky Schedules Files - 19th November 2025

Scheduled for Nov 19, 00:00 - 04:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Oct 22, 2025 - 20:08 UTC

Scheduled

We will be performing planned maintenance to upgrade the SFTP system for Cirium Sky Schedule Files on Wednesday, 19th November, 2025. No downtime is expected and no customer changes are required. Thank you for your understanding. Please contact our help desk if you have any questions.
Posted Oct 22, 2025 - 20:05 UTC
This scheduled maintenance affects: Cirium Sky™ Schedule Files.