Investigating issues with Fleets Analyzer - Aircraft - Summary

Incident Report for Cirium

Update

We are continuing to investigate the issue causing overstated aircraft counts in Fleets Analyzer under Aircraft Summary. Detail and Trend tabs remain unaffected. A further update will be provided no later than 27th March at 09:00 UTC. Please contact our Help Desk with any questions.
Posted Mar 27, 2026 - 01:06 UTC

Investigating

We are investigating an issue with Fleets Analyzer - Aircraft - Summary returning overstated aircraft counts. The Detail and Trend tabs are unaffected. We apologise for any inconvenience caused and will post a further update no later than 27th March, 01:00 UTC.
Posted Mar 26, 2026 - 16:55 UTC
This incident affects: Fleets Analyzer.