Cirium PDS File Delivery Outage - 23rd August 2026

Incident Report for Cirium

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 24, 2026 - 09:32 UTC

Investigating

Cirium PDS deliveries on Sunday 23rd August were affected by an outage from our parent company’s SFTP infrastructure. The missed deliveries from Sunday will be remedied today. Please also note that the SFTP infrastructure is online and working well today (Monday 24th Aug).
Posted Aug 24, 2026 - 09:31 UTC
This incident affects: Professional Data Services.