Values Analyzer - temporary unavailability of Online Values for a subset of assets

Incident Report for Cirium

Resolved

This incident has been resolved and Online Valuations can be ran for all the affected assets. Please accept our apologies for any disruption caused.
Posted Jul 17, 2026 - 08:12 UTC

Identified

Values Analyzer - Online Values are temporarily unavailable due to an issue with the engine maintenance cost data. The following assets are affected:
Boeing 777-200LR, 200LRF, 200LRMF, 300ER, 300ERSF/MF/CF
Boeing 767-300ER, 300ERF, 300SF/BCF, 200ER
CRJ700, CRJ900, CRJ1000
General Electric GE90-110, GE90-115
General Electric CF6-80C2B6F
General Electric CF34-8C5B1, 8C5A2, 8C5A3
Our engineers are working on the data fix. In the meantime, users will be prompted to request a Desktop Valuation.
Please contact our Helpdesk with any questions.
Posted Jul 08, 2026 - 08:48 UTC
This incident affected: Values Analyzer.