FlightStats mobile app performance issues
Incident Report for Cirium
Resolved
This incident has been resolved. Please contact our Helpdesk if you experience any further issues with Flightstats.com or the Flightstats mobile app.
Posted May 16, 2024 - 19:11 UTC
Investigating
We're currently investigating performance issues with our FlightStats mobile app. Please accept our apologies for the inconvenience.
Posted May 02, 2024 - 19:16 UTC
This incident affected: FlightStats.com.