Fleets Analyzer - aircraft duplication

Incident Report for Cirium

Resolved

This issue has been resolved. The aircraft duplication was caused by the release of estimated lease end dates yesterday. We have rolled-back the release and will schedule it for a later date once the data has been fixed. Please accept our apologies for any disruption caused.
Posted Nov 25, 2025 - 15:12 UTC

Investigating

We are currently investigating an issue that is causing duplication of sub-leased aircraft in Fleets Analyzer. Please be aware that aircraft counts may be overstated (depending on filter selections). We will post a further update shortly.
Posted Nov 25, 2025 - 09:52 UTC
This incident affected: Fleets Analyzer.