Data Drop API - file download issues

Incident Report for Cirium

Update

We are continuing to investigate this issue.
Posted Sep 16, 2025 - 17:20 UTC

Investigating

We have received reports of users receiving error messages when trying to download files from the Data Drop API. Our engineers are investigating. A further update will follow. Please contact us if you have questions or require further assistance
Posted Sep 16, 2025 - 15:10 UTC
This incident affects: Cirium Sky™ APIs and Professional Data Services.