This issue, which impacted user login and access to FlightStats.com, has been resolved, and normal service has been fully restored. All necessary corrective actions have been completed, and the platform is stable following post‑resolution monitoring. We sincerely apologize for the inconvenience this may have caused and would like to thank you for your patience and understanding throughout the incident.
Posted May 03, 2026 - 12:30 UTC
Update
This issue, which impacted user login and access to FlightStats.com, has been resolved, and normal service has been fully restored. All necessary corrective actions have been completed, and the platform is stable following post‑resolution monitoring. We sincerely apologize for the inconvenience this may have caused and would like to thank you for your patience and understanding throughout the incident.
Posted May 03, 2026 - 12:24 UTC
Update
Our Engineering team has identified the issue and is actively working on a resolution. Efforts to restore normal login access are ongoing, and we continue to closely monitor the situation. We will provide the next update within the next hour. Thank you for your patience and understanding.
Posted May 03, 2026 - 11:10 UTC
Identified
The issue has been identified, and a fix is currently being implemented. Our Engineering team is actively working on it, and we will continue to provide updates as they become available. Thank you for your understanding.
Posted May 03, 2026 - 11:00 UTC
Investigating
We would like to inform you that we are currently experiencing a service issue affecting access to FlightStats.com, which began at approximately 7:02 UTC on 3 May. During this time, customers may encounter difficulties with logging in and resetting passwords.
Our Engineering team is actively investigating the issue and working to determine the root cause. This matter is being treated as a high‑priority incident. We sincerely apologize for the inconvenience this may cause and greatly appreciate your patience as we work to restore full service. We will share the next update on or before 03 May 2026 at 12:26 UTC. Please contact our Help Desk if you have any questions. Thank you for your understanding.